Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8274 closed enhancement (fixed)

The placeholder doesn't move when dragging outside of container element

Reported by: MoonScript Owned by:
Priority: minor Milestone: 1.8.20
Component: ui.sortable Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description

When the axis option is either 'x' or 'y', I believe any mouse movements in that same direction should update the placeholder position, even if it is outside of the container element area.

Issue can be seen here: http://jsfiddle.net/MoonScript/vLyfU/

And this is how I think it should work: http://jsfiddle.net/MoonScript/vLyfU/6/

Change History (5)

comment:2 Changed 4 years ago by Jason Moon

  • Resolution set to fixed
  • Status changed from new to closed

Sortable: update placeholder when axis is x or y. Fixed #8274 - placeholder doesn't move when dragging outside of container element

Changeset: b8b0c528301ab2bfc49e36143a3c4f6451e58ccd

comment:3 Changed 4 years ago by Jason Moon

Sortable: update placeholder when axis is x or y. Fixed #8274 - placeholder doesn't move when dragging outside of container element (cherry picked from commit b8b0c528301ab2bfc49e36143a3c4f6451e58ccd)

Changeset: 81835fab0c43f18e4033650adaeae2f22d3efd5b

comment:4 Changed 4 years ago by scottgonzalez

  • Milestone changed from 1.9 to 1.8.20

comment:5 Changed 4 years ago by tj.vantoll

#8342 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.