Opened 7 years ago

Last modified 3 years ago

#8342 reopened bug

Sortable: Incorrect behaviour (or incorrect documentation) of sortable option tolerance: 'intersect'

Reported by: dioslaska Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.20
Keywords: Cc:
Blocked by: Blocking:

Description

Here's what the docs sais about the tolerance option:

intersect: draggable overlaps the droppable at least 50%

But if the mouse pointer is not above the sortable items, the sort does not happen, no matter that the dragged element is at least 50% over another sortable item (the functionality I expect) This happens on the demo page as well, tested on all major browsers. It is even more annoying if the drag is restricted on one of the axis.

Here is an example:

http://jsfiddle.net/8hjhV/3/

Here is the expceted behaviour (sort should occur if the dragged element overlaps anouther sortable element, even if the mouse pointer is not over that element) with a workaround solution

http://jsfiddle.net/8hjhV/2/

Change History (11)

comment:1 Changed 6 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 6 years ago by petersendidit

Status: newopen
Summary: Incorrect behaviour (or incorrect documentation) of sortable option tolerance: 'intersect'Sortable: Incorrect behaviour (or incorrect documentation) of sortable option tolerance: 'intersect'

comment:4 Changed 6 years ago by nathanael

comment:5 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #8274.
This was already fixed in 1.8.20 for #8274. You can see that it works here: http://jsfiddle.net/tj_vantoll/tDGgM/. If you change the version from 1.8.20 --> 1.8.19 the bug appears.

comment:6 Changed 6 years ago by tj.vantoll

This is working as expected when the sortable is constrained to an axis per #8274 but the problem still exists when no axis is specified http://jsfiddle.net/tj_vantoll/DdLjd/.

comment:7 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: closedreopened

comment:8 Changed 5 years ago by tj.vantoll

#9524 is a duplicate of this ticket.

comment:9 Changed 5 years ago by tj.vantoll

Updated versions in the test case: http://jsfiddle.net/tj_vantoll/QdcW7/

Per #9524 this also happens on the demo page: http://jqueryui.com/sortable/

comment:10 Changed 5 years ago by tj.vantoll

#10048 is a duplicate of this ticket.

comment:11 Changed 3 years ago by Scott González

#14778 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.