Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8994 closed bug (fixed)

Datepicker: next and prev buttons are disabled when using yearRange

Reported by: Yerel Owned by:
Priority: minor Milestone: 1.10.1
Component: ui.datepicker Version: 1.10.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

The next and prev buttons are disabled with the following example: http://jsfiddle.net/t7YTe/

While they were enabled/clickable in previous versions (like the 1.9.2 version): http://jsfiddle.net/KbLjn/

Change History (7)

comment:1 Changed 7 years ago by Scott González

Keywords: regression added
Milestone: none1.10.1
Status: newopen
Summary: Datepicker issue with next and prev buttonsDatepicker: next and prev buttons are disabled when using yearRange

comment:2 Changed 7 years ago by petersendidit

This is a regression caused by: https://github.com/jquery/jquery-ui/commit/eca5abd873675f5cc7b96641c723b7e35a4260bc

Should have a fix here soon.

comment:4 Changed 7 years ago by David Petersen

Resolution: fixed
Status: openclosed

Datepicker: Handle when yearRange is a year or a modifier. Fixed #8994 - Datepicker: next and prev buttons are disabled when using yearRange

Changeset: 8f7c3e309cae07c75b930c55f14c05053d5028e9

comment:5 Changed 7 years ago by David Petersen

Merge pull request #891 from petersendidit/datepicker_8994

Datepicker: Handle when yearRange is a year or a modifier. Fixed #8994 -...

Changeset: f7f165c9f8281c5fc5d060eb7bfe09921a0aea82

comment:6 Changed 7 years ago by Scott González

#9079 is a duplicate of this ticket.

comment:7 Changed 7 years ago by Scott González

#9085 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.