Opened 4 years ago

Closed 2 years ago

Last modified 2 years ago

#9046 closed bug (fixed)

Slider: Setting both values of range slider to maximum value, locks the slider

Reported by: sup Owned by:
Priority: minor Milestone: 1.12.0
Component: ui.slider Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

The slider handles are locked, after setting both values of range slider to the maximum value. Worked fine with the previous versions (tested 1.8.23 and 1.9.2)

Test case: http://jsbin.com/oyires/1

Change History (10)

comment:1 Changed 4 years ago by petersendidit

  • Status changed from new to open
  • Summary changed from Setting both values of range slider to maximum value, locks the slider to Slider: Setting both values of range slider to maximum value, locks the slider

comment:2 Changed 4 years ago by sup

There is a workaround for this issue, set the values separately (from hight to low index)

// original code
handle.slider('option', { values: [from, to] });

// workaround
handle.slider('values', 1, to);
handle.slider('values', 0, from);

Extended test case: http://jsbin.com/oyires/10/

Last edited 4 years ago by sup (previous) (diff)

comment:3 Changed 4 years ago by lucas.ams

I just fixed this bug. Basically, by the time both handles are set to the maximum value, I give a focus on the first handle. Doing that, the lock is avoided because the user will have control on it (first handle), allowing drag it to the left whenever necessary.

I'll send a pull request.

Last edited 4 years ago by lucas.ams (previous) (diff)

comment:5 Changed 3 years ago by scottgonzalez

#10091 is a duplicate of this ticket.

comment:6 follow-up: Changed 2 years ago by sup

Looks good to me, please close the ticket.

Thank you!

comment:7 in reply to: ↑ 6 Changed 2 years ago by scottgonzalez

Replying to sup:

Looks good to me, please close the ticket.

Why? This hasn't been fixed.

comment:9 Changed 2 years ago by Ablay Keldibek

  • Resolution set to fixed
  • Status changed from open to closed

Slider: Fix handle order when setting values of range slider to max

When both values are set to the maximum change them in descending order

Fixes #9046 Closes gh-1502

Changeset: dff1c74dd4c0fd6b951c7c183bebae09f9f229f6

comment:10 Changed 2 years ago by scottgonzalez

  • Milestone changed from none to 1.12.0
Note: See TracTickets for help on using tickets.