Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9070 closed bug (duplicate)

Sortable: Unstable movements using connectWith

Reported by: joshuaballoch Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery UI's sortable connectWith option has some core instabilities. When: your two sortable element 'bins' or 'buckets' have a width that makes the sortable elements inside push into two or more lines.

What breaks: In this case, the movement of elements within a bin is unstable:

  1. it is hard to move to where you want,
  2. the elements constantly jump around, and
  3. it is impossible to move an element into the first position

Example: http://jsfiddle.net/hf4KG/2/

Removing connectWith returns stability to the sortable lists: http://jsfiddle.net/Vnj8H/1/

Potential Solution: This SO Q+A has found a potential solution to improve stability: http://stackoverflow.com/questions/14514359/jquery-sortable-breaks-when-using-connectwith-on-sortable-grids

I am unsure that this user has submitted a ticket, so I wrote new fiddles and am submitting one here.

Change History (3)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #8792.

comment:2 in reply to:  1 Changed 7 years ago by joshuaballoch

Replying to tj.vantoll:

Duplicate of #8792.

Can we get this ticket re-opened? This is a duplicate of #8972, but that ticket was not resolved: its pull request was refused. As such, that proposed solution was nixed, but the bug remains. (see https://github.com/jquery/jquery-ui/pull/818)

This remains as a core bug, I would hope this could be reopened and resolved.

comment:3 Changed 7 years ago by Scott González

Why would we re-open this ticket? We're aware of the bug, having duplicate tickets open won't get the bug fixed any faster.

Note: See TracTickets for help on using tickets.