Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9287 closed bug (fixed)

Droppable: Scope option cannot be changed after initialization

Reported by: aherbst Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.droppable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

browser: Firefox 18.0.2 OS: Fedora 16 jsFiddle: http://jsfiddle.net/aherbst/gA6ZR/

This issue is summarized in http://stackoverflow.com/questions/3097332/jquery-drag-droppable-scope-issue. Basically, the $.ui.ddmanager.droppables array is not updated when you call

$('.droppable').droppable('option','scope','foo')

So Draggables with the scope 'foo' can no longer be dropped onto that Droppable. In the jsFiddle, if you comment out the 'option' calls on lines 3 and 4, and uncomment the block underneath (which is his solution from StackOverflow), then it works.

Change History (5)

comment:1 Changed 4 years ago by tj.vantoll

Status: newopen
Summary: Setting scope on Droppable via 'option' call does not workDroppable: Scope option cannot be changed after initialization

comment:2 Changed 4 years ago by tj.vantoll

#9639 is a duplicate of this ticket.

comment:4 Changed 4 years ago by Andrei Picus

Resolution: fixed
Status: openclosed

Droppable: update ddmanager when scope changes through setOption. Fixed #9287 - droppable: Scope option cannot be changed after initialization.

Changeset: ffab89e9bee97cf7cc74249b6e4ce9dd798013c9

comment:5 Changed 4 years ago by mikesherov

Milestone: none1.11.0
Note: See TracTickets for help on using tickets.