Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9631 closed bug (fixed)

Autocomplete: default functionality does not announce the suggestions correctly

Reported by: dylanb Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.autocomplete Version: 1.10.3
Keywords: a11y Cc:
Blocked by: Blocking:

Description

Using the demo of the default autocomplete widget, the default functionality does not make its announcements correctly.

The problem with the implementation is the fact that the input field is being updated as the suggestions are traversed and the AT is trying to announce these updates. In addition, there is no attempt being made to get the currently "highlighted" suggestion to announce correctly.

A better solution would be to not update the input field until the user has made a choice and user aria-live to announce the selections as the user traverses through them.

Change History (5)

comment:1 Changed 3 years ago by dylanb

Additional information - with JAWS the autocomplete keeps popping out of forms mode, there are 2 possible solutions to this that will need to be investigated along with the approach chosen to address the announcement problem which affects all screen readers.

comment:2 Changed 3 years ago by tj.vantoll

  • Keywords a11y added
  • Status changed from new to open

comment:3 Changed 3 years ago by tj.vantoll

#9632 is a duplicate of this ticket.

comment:4 Changed 3 years ago by Dylan Barrell

  • Resolution set to fixed
  • Status changed from open to closed

Autocomplete: Announce autocomplete correctly in all ATs.

Fixes #9631 Closes gh-1153

Changeset: 0b28d597fe1857590c9719c8b41f00e77967f7d7

comment:5 Changed 3 years ago by jzaefferer

  • Milestone changed from none to 1.11.0
Note: See TracTickets for help on using tickets.