Opened 11 years ago

Closed 8 years ago

Last modified 7 years ago

#4178 closed bug (fixed)

Accordion animation a bit jumpy in some browsers

Reported by: Scott González Owned by:
Priority: major Milestone: 1.9.0
Component: ui.accordion Version: 1.6rc6
Keywords: Cc:
Blocked by: Blocking:

Description

The animations are out of sync by a few pixels in some cases.

Change History (13)

comment:1 Changed 11 years ago by Scott González

Summary: Accordion animatin a bit jumpy in some browsersAccordion animation a bit jumpy in some browsers

comment:2 Changed 9 years ago by Scott González

Milestone: 1.next1.9
Priority: minormajor

comment:3 Changed 9 years ago by Scott González

Status: newopen

comment:4 Changed 8 years ago by Scott González

#7617 is a duplicate of this ticket.

comment:5 Changed 8 years ago by fiance

The error occurs in Chrome 13.0.782.112 m

comment:6 Changed 8 years ago by speaktorob

This appears to be a case of not correctly calculating margins.

http://jsfiddle.net/speaktorob/mWeV2/4/

comment:7 in reply to:  6 Changed 8 years ago by Scott González

Replying to speaktorob:

This appears to be a case of not correctly calculating margins.

No, it's a problem of trying to keep the sum of all values consistent while updating multiple properties. Removing the margins just reduces the number of places that the sum can be corrupted. You'll notice that bottom one does jump, just less.

comment:8 Changed 8 years ago by Scott González

comment:9 Changed 8 years ago by Scott González

Resolution: fixed
Status: openclosed

Accordion: Rewrote the animation code. Fixes #4178 - Accordion animation a bit jumpy in some browsers. Fixes #7371 - Accordion: Incorrect size when zoomed.

Changeset: 3d9f6b5bc74d09a08f6a116b6b31d93d72971f6d

comment:10 Changed 8 years ago by ORIGINALUSRNM

So this fix is not yet in production, correct? Shouldn't it still be considered open since the most recent fix ( not yet in production) is still not steady cross-browser?

Last edited 8 years ago by ORIGINALUSRNM (previous) (diff)

comment:11 Changed 8 years ago by Scott González

No. The ticket clearly states the milestone for the fix.

comment:12 Changed 8 years ago by Scott González

#8352 is a duplicate of this ticket.

comment:13 Changed 7 years ago by Scott González

Accordion: New approach to synchronizing animations. Fixes #4178 - Accordion animation a bit jumpy in some browsers.

Changeset: d20f05ea37f17ec7799fb4d989c2ecba8689b096

Note: See TracTickets for help on using tickets.