Opened 9 years ago

Last modified 3 years ago

#4985 open bug

Resizable: float: right issues with position: static or position: relative elements

Reported by: devinrayolsen Owned by:
Priority: major Milestone: 2.0.0
Component: ui.resizable Version: 1.7.2
Keywords: float:right; positioned resize elements Cc:
Blocked by: Blocking:

Description

Seems to be an issue with non positioned or relative positioned elements and floating them right while trying to use jQuery UI Resize.

Here is a video of the issue. http://www.screentoaster.com/watch/stVEpSQEJIR1xWRl9ZWF5YU1ZV

Change History (7)

comment:1 Changed 7 years ago by Scott González

Milestone: TBD2.0.0

comment:2 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: Position Relative / Float Right - Resize Issue!Resizable: float: right issues with position: static or position: relative elements

The video link in the original description no longer works but there is some strange behavior when applying float: right to a resizable element - http://jsfiddle.net/tj_vantoll/dnb7E/ float: left; doesn't produce this behavior. As mentioned in the original description if position: absolute; is applied this problem goes away.

I tested this behavior and got similar results in Chrome 22, Firefox 16, and Safari 6.

comment:3 Changed 7 years ago by tj.vantoll

#4346 is a duplicate of this ticket.

comment:4 Changed 7 years ago by tj.vantoll

If anyone stumbles across this a workaround is discussed in the closed duplicate issue https://groups.google.com/forum/?hl=en&fromgroups=#!topic/jquery-ui/Ne09qPX-L0w.

comment:5 Changed 6 years ago by tj.vantoll

#9140 is a duplicate of this ticket.

comment:6 Changed 6 years ago by tj.vantoll

#8665 is a duplicate of this ticket.

comment:7 Changed 3 years ago by Clayton Watts

Bug also applies to table-cell and flexbox columns with west handles and rows with north handles.

Note: See TracTickets for help on using tickets.