Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6748 closed bug (fixed)

animateClass broken in 1.8.7

Reported by: Corkup Owned by:
Priority: blocker Milestone: 1.8.8
Component: ui.effects.core Version: 1.8.7
Keywords: Cc:
Blocked by: Blocking:

Description

After the update to 1.8.7 the animations through toggleClass doesn't work anymore. Reverting to 1.8.6 or copying the $.effects.animateClass function from 1.8.6 and it works again.

test cases: 1.8.7 http://jsbin.com/ulexo3 1.8.6 http://jsbin.com/ulexo3/2

Change History (7)

comment:1 Changed 9 years ago by Scott González

Priority: minorblocker
Status: newopen

This bug only occurs when the element isn't currently being animated. For example, this works:

$( "#elem" ).delay( 500 ).addClass( "foo" );

comment:2 Changed 9 years ago by Scott González

Resolution: fixed
Status: openclosed

Effects: Fixed queueing of class animations. Fixes #6748 - animateClass broken in 1.8.7.

Changeset: 6731b0e2d60a16611c25cd248318a4076bd4494d

comment:3 Changed 9 years ago by Scott González

Effects: Fixed queueing of class animations. Fixes #6748 - animateClass broken in 1.8.7.

Changeset: cba92afe257e51e18ca2bb2161559e8928e82fad

comment:4 Changed 9 years ago by Scott González

Milestone: 1.91.8.8

comment:5 Changed 9 years ago by Scott González

#6794 is a duplicate of this ticket.

comment:6 Changed 9 years ago by Scott González

#6815 is a duplicate of this ticket.

comment:7 Changed 9 years ago by Scott González

#6833 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.