Opened 7 years ago

Closed 6 years ago

#8023 closed bug (invalid)

Resizable: Bug with scroll of ancestors

Reported by: tysauron Owned by: tysauron
Priority: minor Milestone: 2.0.0
Component: ui.resizable Version: 1.8.17
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

during a resize only the scroll of the div parent and requests into account

Correction resize.js ln 258 replaced

if (o.containment) {
curleft + = $ (o.containment). scrollLeft () | | 0;
curtop + = $ (o.containment). scrollTop () | | 0;
}

by

$ (el). parents (). each (function () {
                         containerElement var = $ (this);
curleft containerElement.scrollLeft + = () | | 0;
curtop containerElement.scrollTop + = () | | 0;
});

Change History (4)

comment:1 Changed 7 years ago by Scott González

Description: modified (diff)
Summary: Bug quand resize dans une div qui a pour parent une autre div avec scrollResizable: Bug with scroll of ancestors

comment:2 Changed 6 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 6 years ago by tj.vantoll

Owner: set to tysauron
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! Can you please provide a reduced test case showing the issue that this creates? To get you started, you can use this boilerplate: http://jsfiddle.net/ZgAqH/ Open the link and click to "Fork" (in the top menu).

I gave it a shot and can't create any issues http://jsfiddle.net/tj_vantoll/YwMXS/. This also might be a duplicate of #3815, #4701, or #7485.

comment:4 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.