Opened 4 years ago

Closed 2 years ago

#9477 closed bug (fixed)

Effect: .ui-effects-wrapper not following element's display, vertical-align, etc. makes trouble

Reported by: euyuil Owned by: mikesherov
Priority: minor Milestone: 1.12.0
Component: ui.effects.core Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Here is a pull request at Github, maybe the discussion will help.

An example shows that currently the latest version of jQuery 1.10.2 and jQuery UI 1.10.3 don't follow element's display property when creating a wrapper for it and make the effect seems wrong. @tjvantoll showed a clearer example.

After that I discovered another example, showing that not following vertical-align property of the element will cause problem too.

So I guess maybe there are even more of them but I haven't found any until now.

Change History (6)

comment:1 Changed 3 years ago by tj.vantoll

#9690 is a duplicate of this ticket.

comment:2 Changed 3 years ago by tj.vantoll

Status: newopen

When the effects rewrite lands we'll have to see if this is still relevant.

comment:3 Changed 3 years ago by mikesherov

Owner: set to mikesherov
Status: openassigned

comment:4 in reply to:  2 Changed 3 years ago by mikesherov

Replying to tj.vantoll:

When the effects rewrite lands we'll have to see if this is still relevant.

I won't be, but I'm accepting just to make sure :-)

comment:5 Changed 3 years ago by mikesherov

Milestone: none1.12.0

This is indeed fixed by the effects rewrite.

comment:6 Changed 2 years ago by Mike Sherov

Resolution: fixed
Status: assignedclosed

Effects: Rewrite

  1. Introduces a set of helper methods to easily create and define new effects.
  2. Uses clip animations and placeholders instead of wrappers for clip effects.
  3. Ensures all animations are detectable as animated

Fixes #10599 Fixes #9477 Fixes #9257 Fixes #9066 Fixes #8867 Fixes #8671 Fixes #8505 Fixes #7885 Fixes #7041

Closes gh-1017

Changeset: b6bec797d6a8ef0b377a866c38c67e66a626b45f

Note: See TracTickets for help on using tickets.