Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8522 closed bug (fixed)

Calendar doesn't render when moving between datepicker controls

Reported by: markallgood Owned by:
Priority: minor Milestone: git
Component: ui.datepicker Version: 1.9.0-rc.1
Keywords: Cc:
Blocked by: Blocking:

Description

When entering a datepicker control text input after leaving another datepicker control on the same page, the calendar is not rendered.

This jsfiddle demonstrates the problem... http://jsfiddle.net/markallgood/vmZVS/

-- Seems to be a jQuery UI 1.9 (including RC) issue. jQuery UI 1.8.23 doesn't do this. -- Replicated the problem on Windows 7 using the Chrome 21.0.1180.83 m, Firefox 14.0.1 and IE 9 and on Mac OS X 10.8.1 using Chrome 21.0.1180.82 and Safari 6.

Change History (5)

comment:1 Changed 7 years ago by Scott González

Resolution: fixed
Status: newclosed

Revert "Datepicker: Modified _updateDatepicker to not update display if updated instance is not current instance." This revert fixes a more serious problem: Fixes #8522 - Calendar doesn't render when moving between datepicker controls.

This reverts commit b4ef2f7ebb1162f75d8fa3276d73e4746bcace84.

Changeset: 6e7bd4d895930a181e98af22f36e6e823d1c0b5a

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.0git

Changing milestone to git to keep this out of the 1.9.0 changelog since it only existed in a pre-release.

comment:3 Changed 7 years ago by Scott González

#8607 is a duplicate of this ticket.

comment:4 Changed 7 years ago by Scott González

#8620 is a duplicate of this ticket.

comment:5 Changed 7 years ago by Scott González

#8634 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.