Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9759 closed bug (notabug)

Dialog: Broken images on CDN and quick download

Reported by: Choppel Owned by:
Priority: blocker Milestone: 1.11.0
Component: ui.dialog Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

When creating a modal dialog the background is not continuously one colour.

http://jqueryui.com/dialog/#modal http://jqueryui.com/dialog/#modal-confirmation

Change History (16)

comment:1 Changed 5 years ago by tj.vantoll

Status: newopen
Summary: Modal Dialog - Overlay is not continuousDialog - Issue with overlay image

comment:2 Changed 5 years ago by Scott González

#9791 is a duplicate of this ticket.

comment:3 Changed 5 years ago by FlashJunior

comparison of some images: http://jsfiddle.net/FlasJunior/zfEAQ/9/

comment:4 Changed 5 years ago by Scott González

#9851 is a duplicate of this ticket.

comment:5 Changed 5 years ago by Scott González

Milestone: none1.11.0
Priority: minorblocker

comment:6 Changed 5 years ago by Scott González

Summary: Dialog - Issue with overlay imageDialog: Broken images on CDN and quick download

comment:7 Changed 5 years ago by Scott González

#9922 is a duplicate of this ticket.

comment:8 Changed 5 years ago by schwarzenneger

The resize icons on dialogs is broken as well; see http://jqueryui.com/dialog/#modal and notice that:

(i) the horizontal bar is there (set the background-image to none might fix this)

(ii) bottom right corner has resize handle but no icon (background image position is wrong)

comment:9 in reply to:  8 Changed 5 years ago by Scott González

Replying to schwarzenneger:

The resize icons on dialogs is broken as well

That's unrelated and not broken. See #4575.

comment:10 Changed 5 years ago by rxaviers

Live download builder produces correct images. For example:

1.10.3: http://code.jquery.com/ui/1.10.3/themes/smoothness/images/ui-bg_flat_0_aaaaaa_40x100.png live: http://download.jqueryui.com/themeroller/images/ui-bg_flat_0_aaaaaa_40x100.png

Issue might have happened during release.

comment:11 Changed 5 years ago by rxaviers

Although themeroller code is supposed to work using any ImageMagick version (https://github.com/jquery/download.jqueryui.com/issues/132). It's true for linux. But, not for mac (https://github.com/jquery/download.jqueryui.com/issues/144).

So, we need to either: (a) figure out what's wrong with #144 on Mac; or (b) release packages using a controlled environment.

comment:12 Changed 5 years ago by Scott González

Resolution: notabug
Status: openclosed

We've addressed the cause of the issue, so I'm now going to close this, even though the CDNs will forever host the broken images. This will be closed as not a bug since it has nothing to do with the source code of jQuery UI.

comment:13 Changed 5 years ago by Scott González

#10031 is a duplicate of this ticket.

comment:14 Changed 5 years ago by Scott González

#10033 is a duplicate of this ticket.

comment:15 Changed 5 years ago by Scott González

#10041 is a duplicate of this ticket.

comment:16 Changed 5 years ago by Scott González

#10044 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.